System Requirements

This site has been optimized for the browsers listed below. Some pages and applications may require specific browsers or newer versions.  In order to properly view the site, Javascript should be enabled in the selected browser (enabled is the default setting).

  • Chrome 39+
  • Firefox 31+
  • Microsoft Edge 38+ (Windows 10 Anniversary Update or newer)
  • Internet Explorer 11
  • Safari 8+ (Mac OS)


Some applications, such as Google Translate, will not work in Internet Explorer.  If translation services are required, please use one of the other listed browsers.

Operating systems other than or older than Windows 10 should have Acrobat Reader installed in order to properly view most documents posted on the site.